Why is my Custom Domain not working?

Here are some common errors which can cause issues with your custom domain setup:

  1. Your CNAME Record is not pointing to "domain.pixieset.com"
    When you are creating a CNAME record, you will need to enter in "domain.pixieset.com", under the "Points to" field. Please ensure you are entering "domain.pixieset.com", exactly as shown. Important: Do not enter your username associated with your Pixieset account.

    Correct: domain.pixieset.com 
    Incorrect: yourusername.pixieset.com


  2. Incorrect Record Type created
    Please ensure you are creating an entry under CNAME record. Your custom domain will not work if you have created the entry under any other Record Types (such as an A Record, or an ALIAS Record). 


  3. You are not making the changes at where your DNS is hosted
    You will need to create the CNAME record entry at where your domain is being hosted, keep in mind that this might not necessarily be the same place as where you purchased the domain from. For example, if you have purchased your domain from GoDaddy, and use Bluehost for hosting, you will need to make the adjustments to your domain under Bluehost, and not GoDaddy. 


  4. You have not saved the Custom Domain on Pixieset
    After you create your Custom Domain, you will need to go back to your Pixieset account and enter the Custom Domain to have it registered with your Pixieset Account. This can be done by going to Account Settings (person icon on the top right) > Options > Custom Domain. 

    Correct: gallery.yourdomain.com 
    Incorrect: https://gallery.yourdomain.com/ 
    Incorrect: yourdomain


  5. DNS changes can take up to 72 hours to propagate across the Internet
  6. You might not be able to see the pages working immediately after you have created and saved the custom domain. Please ensure you have all the above set up correctly, and wait for the changes to take effect.

If the above settings are all correct, and you're still experiencing errors with your Custom Domain after 72 hour, please get in touch with us at support@pixieset.com and we would be happy to help you troubleshoot further! Please also include a screenshot of your current Custom Domain set up to allow us to faster troubleshoot and investigate the error.

Related Articles: 
Setting up a Custom Domain 

Feedback and Knowledge Base